Problem On A Ge Logiq 3 - Preste serviços de manutenção a técnicos Forum

problem on a GE Logiq 3

Tags: Ultrasound, GE

(1)

simon garzo

problem on a GE Logiq 3

January 24, 2020 09:57

Good morning, I have a problem in which the team drags the operating system perfectly, but the moment of performing the exam, the image is very weak as if the wave had no strength or very low level of wave, I thought they were the translators but the I tried a GE Logiq 3 Pro device and they work well, so I don't know what happens, can you please guide me on the subject? Sorry for my bad English since I'm using the Google translator, I'm from Venezuela

Log inor Register

to rate and post a comment

(379)
(57)
(12)

Ricardo A. Sanchez

re: problem on a GE Logiq 3

January 27, 2020 10:15

Please check the High Voltage Power supply

Log inor Register

to rate and post a comment

(127)
(20)
(11)

Augustine Kobla Amenyo

re: re: problem on a GE Logiq 3

April 03, 2020 10:26

Please Richardo, my GE Logiq 3 pro some times you will hear the relays click then the probes image appear, but another moment no relay clicking sound and no image appears. Any help from your expertise?

Log inor Register

to rate and post a comment

(379)
(57)
(12)

Ricardo A. Sanchez

re: re: re: problem on a GE Logiq 3

April 07, 2020 10:42

Have you tried to reload the software?

Log inor Register

to rate and post a comment

Repairs for less with FREE Transducer EVALS! CALL NOW 1-888-838-7488

If you have a broken or defective probe, why not attempt to repair before purchasing? This could save you $1,000’s! With a free evaluation we can let you know the cost of repair if applicable. Call today: 1-888-838-7488 Email: sales@sentinelimaging.net

DOTmed Certified
advertisement

 

 

Hitachi

 

 

RSTI Newsletter